All checks were successful
Check Flake / check-flake (push) Successful in 1m50s
19 lines
291 B
Nix
19 lines
291 B
Nix
{ lib, pkgs, config, ... }:
|
|
with lib;
|
|
let
|
|
cfg = config.nix.flakes;
|
|
in
|
|
{
|
|
options.nix.flakes = {
|
|
enable = mkEnableOption "use nix flakes";
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
nix = {
|
|
extraOptions = ''
|
|
experimental-features = nix-command flakes
|
|
'';
|
|
};
|
|
};
|
|
}
|